FlatFrog Board System Requirements

FlatFrog Board can be accessed at app.flatfrog.com.

Supported browsers on Windows, MacOS, and iPadOS:

  • Google Chrome (78+)
  • Apple Safari (14+)
  • Microsoft Edge (80+)
  • Firefox (53+)
  • Opera (65+)